[IQUG] Restore of IQ snapshot

Ron Watkins rwatkins at dssolutions.com
Thu Aug 24 10:57:26 MST 2017


I can check, but the fact that it works sometimes and not others makes me think it’s not a symlink issue.

Ron

 

From: Mumy, Mark [mailto:mark.mumy at sap.com] 
Sent: Thursday, August 24, 2017 10:28 AM
To: Ron Watkins; Baker, Chris; iqug at iqug.org
Subject: Re: [IQUG] Restore of IQ snapshot

 

Check out this old thread:

http://www.iqug.org/archive/2008/001280.html

 

David had the same issue.  Turns out it was a symlink issue.  Any chance you have thinks pointing to the wrong area?

 

Mark

 

Mark Mumy

Strategic Technology Incubation Group

Customer Innovation and Enterprise Platform |  SAP

M +1 347-820-2136 | E  <mailto:mark.mumy at sap.com> mark.mumy at sap.com

My Blogs: https://blogs.sap.com/author/markmumy/

                       

 <https://sap.na.pgiconnect.com/I825063> https://sap.na.pgiconnect.com/I825063

Conference tel: 18663127353,,8035340905#

                     
id:image001.png at 01D27BD7.A4E48330

 

From: "iqug-bounces at iqug.org" <iqug-bounces at iqug.org> on behalf of Ron Watkins <rwatkins at dssolutions.com>
Date: Thursday, August 24, 2017 at 19:52
To: Chris Baker <c.baker at sap.com>, "iqug at iqug.org" <iqug at iqug.org>
Subject: Re: [IQUG] Restore of IQ snapshot

 

I don’t have an exact value, but it’s not very high.

 

From: Baker, Chris [mailto:c.baker at sap.com] 
Sent: Thursday, August 24, 2017 6:53 AM
To: Ron Watkins; iqug at iqug.org
Subject: RE: [IQUG] Restore of IQ snapshot

 

Out of curiosity, how busy is the CPU of the host at that time?  I’m wondering if the IQ server is not able to make an OS call to get the datetime, or nothing returns from the host.

 

Probably worth a look by engineering.

 

Chris

 

Chris Baker | Database Engineering Evangelist | CERT | PI HANA Platform Data Management | SAP

T +1 416-226-7033 <tel:+1%20416-226-7033>  | M +1 647-224-2033 <tel:+1%20647-224-2033>  | TF +1 866-716-8860 <tel:+1%20866-716-8860> 

SAP Canada Inc. 445 Wes Graham Way, Waterloo, N2L 6R2 <x-apple-data-detectors://17/1> 

c.baker at sap.com | www.sap.com <http://www.sap.com/> 

 

https://sap.na.pgiconnect.com/I826572

Conference tel: 1-866-312-7353,,9648565377# <tel:1-866-312-7353,,9648565377%23> 

 

From: Ron Watkins [mailto:rwatkins at dssolutions.com] 
Sent: Thursday, August 24, 2017 9:48 AM
To: Baker, Chris <c.baker at sap.com>; iqug at iqug.org
Subject: RE: [IQUG] Restore of IQ snapshot

 

Im actually restoring on the same host using a set of soft-linked snapshot luns, so server time doesn’t come into play here.

Specifically, it sais the datetime is “0”, which is an odd value. As is normal, a re-run of exactly the same steps resolved the issue.

This is a periodic issue, happens only sometimes. Im thinking something in the virtual backup is not being set correctly and the restore is picking up that invalid value.

I cannot reproduce on demand, but it does happen fairly frequently, probably once a week or so.

 

From: Baker, Chris [mailto:c.baker at sap.com] 
Sent: Thursday, August 24, 2017 6:39 AM
To: Ron Watkins; iqug at iqug.org
Subject: RE: [IQUG] Restore of IQ snapshot

 

I haven’t seen this before, but does the time of the restore node match the time of the backed up node or is the IQ restore trying to restore on what is effectively an earlier time?  Are they the same timezone (and is it a valid definition of a timezone).  Also make sure your client (if not running on the node) also has its time set correctly.

 

I generally set all nodes to use the same NTP server to ensure they are all in sync and there is no drifting.

 

If the times are the same, then you may need to open a support ticket.  Perhaps we are missing something to do with timezones, etc.

 

Also make sure all nodes are up-to-date with OS patches.  I always see a timezone patch when I run an update.

 

Chris

 

Chris Baker | Database Engineering Evangelist | CERT | PI HANA Platform Data Management | SAP

T +1 416-226-7033 <tel:+1%20416-226-7033>  | M +1 647-224-2033 <tel:+1%20647-224-2033>  | TF +1 866-716-8860 <tel:+1%20866-716-8860> 

SAP Canada Inc. 445 Wes Graham Way, Waterloo, N2L 6R2 <x-apple-data-detectors://17/1> 

c.baker at sap.com | www.sap.com <http://www.sap.com/> 

 

https://sap.na.pgiconnect.com/I826572

Conference tel: 1-866-312-7353,,9648565377# <tel:1-866-312-7353,,9648565377%23> 

 

From: iqug-bounces at iqug.org [mailto:iqug-bounces at iqug.org] On Behalf Of Ron Watkins
Sent: Thursday, August 24, 2017 9:29 AM
To: iqug at iqug.org
Subject: [IQUG] Restore of IQ snapshot

 

When performing a restore of IQ virtual backup to snapshot luns, I sometimes get this error. Does anyone recognize the error? It doesn’t happen all the time, just sometimes.

 



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://iqug.org/pipermail/iqug/attachments/20170824/eaba151d/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 1206 bytes
Desc: not available
URL: <http://iqug.org/pipermail/iqug/attachments/20170824/eaba151d/attachment-0002.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.png
Type: image/png
Size: 12070 bytes
Desc: not available
URL: <http://iqug.org/pipermail/iqug/attachments/20170824/eaba151d/attachment-0003.png>


More information about the IQUG mailing list